Airsoft Canada
http://triggerairsoft.com/shop/

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

rapid semi auto blowing fuse, but burst is just fine

:

Doctor's Corner

Reply
 
Thread Tools
Old December 24th, 2017, 01:12   #1
abugroza
 
Join Date: Dec 2017
Location: Indonesia
rapid semi auto blowing fuse, but burst is just fine

hi guys i got a problem which i've been wandering around but not avail to find the solution or kinda but i'm not sure with my budget

i got dboys m4 which i slapped in m120 g&p high-speed, 18:1 gears (no DSG ofc), super-shooter m120 spring, shs steel teeth (weight around 20g) piston

and wired with irlb3034 mosfet, and fuse (glass one gonna change to blade but too lazy to moved up hehehe)

the reason i wired irlb3034 is because i just got a cheap military action brand switch assembly (i bought it in rush in my local store, and i'm not live in canada tho) and my personal preference of shooting is semi-auto

but another problem occur when i try to shoot it in rapid fire, the fuse blown up (30A last try), but after slapping a new fuse and tried full auto, it works fine even back when i use 25 one

how do i solve it? with torque motor or is it limitation of my aeg built

Last edited by abugroza; December 24th, 2017 at 01:13.. Reason: forgot to put some word "and trying to full auto"
abugroza is offline   Reply With Quote
Old December 26th, 2017, 00:28   #2
ThunderCactus
Not Eye Safe, Pretty Boy Maximus on the field take his picture!
 
ThunderCactus's Avatar
 
Join Date: Feb 2007
Semi auto builds up more heat because of the start spikes.
Fuses blow due to heat, not specifically amperage.
The G&P motors are complete shit to start with, so i wouldnt be surprised if thats your exact problem right there.
Get a tienly or asg motor, like a 30 or 35k
ThunderCactus is offline   Reply With Quote
Old February 6th, 2018, 08:11   #3
abugroza
 
Join Date: Dec 2017
Location: Indonesia
ah sorry for reeeeeaaally late reply

the problem is there's a washer thick on bevel and sometimes it make resistant, so i custom fit it and reshim again

the unit now can be shot fast without make the wiring getting hot
abugroza is offline   Reply With Quote
Old February 6th, 2018, 17:04   #4
Styrak
 
Styrak's Avatar
 
Join Date: Jan 2007
Location: Saskatoon, SK
Send a message via MSN to Styrak
Yup too tight shimming will cause a lot of issues.
__________________

Airsoft Sales and Repair/Upgrade Services
Styrak is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
http://triggerairsoft.com/shop/

All times are GMT -4. The time now is 19:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.