Airsoft Canada
Airsoft Depot

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

Xcortech 501 MK2 Tracer Trouble

:

Doctor's Corner

Reply
 
Thread Tools
Old January 23rd, 2017, 15:26   #1
Battalia
 
Join Date: Jan 2009
Location: Calgary
Send a message via MSN to Battalia
Xcortech 501 MK2 Tracer Trouble

Myself and a friend decided to purchase the Xcortech 501 MK2 Tracer Units. Out of the box they worked great, and all basement plinks checked out. Even the first game with them was checking out nicely. However with about 30 mins left in the game BOTH our tracer units would begin to shut off after shooting more than 1 BB per second. We toughed it out, and then ended the night pretty satisfied.

Now however, the units refuse to turn back on. Normal operation is to click the button once, and it will boot up and flash every now and then to indicate it is on. Ours however turn on and flash the tracer, then the light goes off once with another flash of the tracer and then powers down. I've looked at all the manuals and all the other documentation I can get my hands on, and nothing talks about this.

One tracer unit is trouble, but two tracer units doing the same thing can't be coincidence.

Batteries are brand new, and even with different ones the problem persists. The tracer does have a battery indicator but the light is green, so it's not the batteries. If I sit and press the power button for about 5-10 mins the tracer MAY wake up and function normally for a short period of time. However, turning it off sends it back into this coma. When it did wake up, I walked through the "options" menu, and found it set to 4 for power (high) and 2 for APO On (Auto-power off after 30 mins) which I then set to APO Off thinking that may be the issue, but unfortunately it was not the solution.

I've sent in an e-mail to xcortech, but I don't expect an answer. Unless someone here knows what the heck this thing is TRYING to do, then my only recourse will be contacting the retailer and asking for assistance/refund, and I'd hate to do that. The tracer unit does work great when it wants to work.

Thanks in advance to anyone that can help!
Battalia is offline   Reply With Quote
Old February 2nd, 2017, 10:59   #2
Battalia
 
Join Date: Jan 2009
Location: Calgary
Send a message via MSN to Battalia
Well, as an update to anyone else who may stumble on this thread with this issue... It's pretty frustratingly easy to fix.

After a broken english response came in from Xcortech (which I'm thankful they did take the time to respond) They informed me I had to use Alkaline batteries in their tracers. I rolled my eyes, went to the store, grabbed a new pack of AAA's, took out my (old) brand new batteries, installed new ones that were the exact same brand and type (doh! Was sure nothing was gonna happen at this point) Aaaaand it's working now. For how long, I'm not sure. Perhaps a bad batch of batteries from duracell? I'm not sure. Either way, with the new new batteries, it powers on and off without issue. If it does the same thing after a game however, I'll update this thread. Really hope this tracer doesn't cook batteries.
Battalia is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
Airsoft Depot

All times are GMT -4. The time now is 09:04.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.